Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / media / themes / blackshade.msstyles / CMakeLists.txt
diff --git a/media/themes/blackshade.msstyles/CMakeLists.txt b/media/themes/blackshade.msstyles/CMakeLists.txt
new file mode 100644 (file)
index 0000000..17cffe0
--- /dev/null
@@ -0,0 +1,23 @@
+
+list(APPEND TEXTFILES
+    textfiles/ExtraLargeNormal.INI
+    textfiles/LargeFontsNormal.INI
+    textfiles/NormalNormal.INI)
+
+file(MAKE_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/textfiles)
+foreach(_file ${TEXTFILES})
+    get_filename_component(_file_name ${_file} NAME_WE)
+    string(REPLACE ${CMAKE_SOURCE_DIR} ${CMAKE_BINARY_DIR} _converted_file "${_file}")
+    string(REPLACE ${_file_name} "${_file_name}_utf16" _converted_file ${_converted_file})
+    set(_file ${CMAKE_CURRENT_SOURCE_DIR}/${_file})
+    set(_converted_file ${CMAKE_CURRENT_BINARY_DIR}/${_converted_file})
+    add_custom_command(OUTPUT ${_converted_file}
+                       COMMAND native-utf16le ${_file} ${_converted_file}
+                       DEPENDS native-utf16le ${_file})
+    list(APPEND _converted_files ${_converted_file})
+endforeach()
+
+set_source_files_properties(blackshade.rc PROPERTIES OBJECT_DEPENDS "${_converted_files}")
+add_library(blackshade.msstyles SHARED blackshade.rc)
+set_module_type(blackshade.msstyles module)
+set_target_properties(blackshade.msstyles PROPERTIES SUFFIX "")
\ No newline at end of file