[SHELL32_APITEST] Improve the existing PCH and make use of it. Convert AddCommas...
[reactos.git] / modules / rostests / apitests / shell32 / CMakeLists.txt
index 48c4182..a30f8db 100644 (file)
@@ -1,12 +1,12 @@
 
-spec2def(shell32_apitest.exe shell32_apitest.spec)
-
 set_cpp(WITH_RUNTIME)
 
+spec2def(shell32_apitest.exe shell32_apitest.spec)
+
 include_directories(${REACTOS_SOURCE_DIR}/sdk/lib/atl)
 
-add_executable(shell32_apitest
-    AddCommas.c
+list(APPEND SOURCE
+    AddCommas.cpp
     Control_RunDLLW.cpp
     CFSFolder.cpp
     CMyComputer.cpp
@@ -18,10 +18,16 @@ add_executable(shell32_apitest
     ShellExecuteEx.cpp
     shelltest.cpp
     SHParseDisplayName.cpp
+    shelltest.h)
+
+add_executable(shell32_apitest
+    ${SOURCE}
     testlist.c
     resource.rc
     ${CMAKE_CURRENT_BINARY_DIR}/shell32_apitest.def)
+
 target_link_libraries(shell32_apitest wine uuid ${PSEH_LIB})
 set_module_type(shell32_apitest win32cui)
 add_importlibs(shell32_apitest user32 gdi32 shell32 ole32 oleaut32 advapi32 shlwapi msvcrt kernel32 ntdll)
+add_pch(shell32_apitest shelltest.h SOURCE)
 add_rostests_file(TARGET shell32_apitest)