[CMAKE] Get rid of replace_compile_flags
[reactos.git] / modules / rostests / winetests / CMakeLists.txt
index 45a146c..abf5f5e 100644 (file)
@@ -2,16 +2,18 @@
 add_definitions(-D__ROS_LONG64__)
 
 if(MSVC)
-    add_compile_flags("/wd4090") # C4090: 'function': different 'const' qualifiers
-    add_compile_flags("/wd4133") # C4133: 'function': incompatible types - from '<enum> *' to 'UINT *'
-    add_compile_flags("/wd4146") # C4146: unary minus operator applied to unsigned type, result still unsigned
-    add_compile_flags("/wd4189") # C4189: 'x': local variable is initialized but not referenced
-    add_compile_flags("/wd4267") # C4267: '=': conversion from 'size_t' to 'int', possible loss of data
-    add_compile_flags("/wd4305") # C4305: '=': truncation from 'double' to 'FLOAT'
+    add_compile_options(
+        /wd4090 # C4090: 'function': different 'const' qualifiers
+        /wd4133 # C4133: 'function': incompatible types - from '<enum> *' to 'UINT *'
+        /wd4146 # C4146: unary minus operator applied to unsigned type, result still unsigned
+        /wd4189 # C4189: 'x': local variable is initialized but not referenced
+        /wd4267 # C4267: '=': conversion from 'size_t' to 'int', possible loss of data
+        /wd4305) # C4305: '=': truncation from 'double' to 'FLOAT'
     if(ARCH STREQUAL "amd64")
-        add_compile_flags("/wd4101") # C4101: 'x': unreferenced local variable
-        add_compile_flags("/wd4312") # C4312: 'type cast': conversion from 'unsigned int' to 'char *' of greater size
-        add_compile_flags("/wd4334") # C4334: '<<': result of 32-bit shift implicitly converted to 64 bits (was 64-bit shift intended?)
+        add_compile_options(
+            /wd4101 # C4101: 'x': unreferenced local variable
+            /wd4312 # C4312: 'type cast': conversion from 'unsigned int' to 'char *' of greater size
+            /wd4334) # C4334: '<<': result of 32-bit shift implicitly converted to 64 bits (was 64-bit shift intended?)
     endif()
 endif()