[CMAKE] Some options are only supported by GCC, don't use them for clang
[reactos.git] / modules / rostests / winetests / user32 / CMakeLists.txt
index 1321700..32f8993 100644 (file)
@@ -40,7 +40,9 @@ add_executable(user32_winetest
 if(MSVC)
     # Disable warning C4477 (printf format warnings)
     remove_target_compile_option(user32_winetest "/we4477")
-elseif(GCC)
+endif()
+
+if(CMAKE_C_COMPILER_ID STREQUAL "GNU")
     target_compile_options(user32_winetest PRIVATE -Wno-format-overflow)
 endif()