[USER32_WINETEST] Add a PCH.
[reactos.git] / modules / rostests / winetests / user32 / CMakeLists.txt
index 041e696..fc73d16 100644 (file)
@@ -1,4 +1,7 @@
 
+remove_definitions(-DWINVER=0x502 -D_WIN32_WINNT=0x502)
+add_definitions(-DWINVER=0x600 -D_WIN32_WINNT=0x600)
+
 list(APPEND SOURCE
     broadcast.c
     class.c
@@ -24,9 +27,14 @@ list(APPEND SOURCE
     win.c
     winstation.c
     wsprintf.c
-    testlist.c)
+    precomp.h)
+
+add_executable(user32_winetest
+    ${SOURCE}
+    testlist.c
+    resource.rc)
 
-add_executable(user32_winetest ${SOURCE} resource.rc)
+add_pch(user32_winetest precomp.h SOURCE)
 # some tests need to be run from an app compiled as GUI
 set_module_type(user32_winetest win32gui)
 add_importlibs(user32_winetest user32 gdi32 advapi32 msvcrt kernel32)