[BTRFSLIB]
[reactos.git] / reactos / CMakeLists.txt
index dea6232..d90eef1 100644 (file)
@@ -37,12 +37,8 @@ set(CMAKE_COLOR_MAKEFILE OFF)
 #set_property(GLOBAL PROPERTY RULE_MESSAGES OFF)
 set(CMAKE_SKIP_INSTALL_RULES ON)
 
-if(NOT CMAKE_VERSION STREQUAL "2.8.12.1-ReactOS")
-    set(CMAKE_DISABLE_NINJA_DEPSLOG TRUE)
-endif()
-
 if(NOT DEFINED NEW_STYLE_BUILD)
-    set(NEW_STYLE_BUILD FALSE)
+    set(NEW_STYLE_BUILD TRUE)
 endif()
 
 if(NOT ARCH)
@@ -124,6 +120,9 @@ else()
         include(cmake/host-tools.cmake)
     endif()
 
+    # Print build type
+    message("-- Build Type: ${CMAKE_BUILD_TYPE}")
+
     # adjust the default behaviour of the FIND_XXX() commands:
     # search headers and libraries in the target environment, search
     # programs in the host environment