[MSCONFIG_NEW]
[reactos.git] / reactos / base / applications / msconfig_new / CMakeLists.txt
index 20b9760..44a5812 100644 (file)
@@ -10,14 +10,14 @@ include_directories(
 
 list(APPEND C_SOURCE
     comctl32ex/listviewfuncs.c
-    # srvpage.c
-    # systempage.c
-    # startuppage.c
-    # freeldrpage.c
     fileextractdialog.c
     fileutils.c
+    freeldrpage.c
     generalpage.c
     msconfig.c
+    # srvpage.c
+    # systempage.c
+    # startuppage.c
     stringutils.c
     utils.c)
 
@@ -31,5 +31,5 @@ add_executable(msconfig_new ${C_SOURCE} ${CPP_SOURCE} msconfig.rc)
 add_pch(msconfig_new precomp.h CPP_SOURCE)
 set_module_type(msconfig_new win32gui UNICODE)
 target_link_libraries(msconfig_new comsupp)
-add_importlibs(msconfig_new user32 advapi32 version comctl32 comdlg32 ole32 oleaut32 msxml3 shell32 shlwapi msvcrt kernel32)
+add_importlibs(msconfig_new user32 gdi32 comctl32 comdlg32 advapi32 version ole32 oleaut32 msxml3 shell32 shlwapi msvcrt kernel32)
 add_cd_file(TARGET msconfig_new DESTINATION reactos/system32 FOR all)