[RAPPS]
[reactos.git] / reactos / base / applications / rapps / CMakeLists.txt
index e3a053e..ee33a60 100644 (file)
@@ -1,6 +1,4 @@
 
-set_unicode()
-
 list(APPEND SOURCE
     aboutdlg.c
     available.c
@@ -23,13 +21,11 @@ include_directories(
     ${CMAKE_CURRENT_BINARY_DIR}
     ${REACTOS_BINARY_DIR}/include/reactos)
 
-set_rc_compiler()
-
 add_executable(rapps ${SOURCE})
-set_module_type(rapps win32gui)
+add_pch(rapps rapps.h)
+set_module_type(rapps win32gui UNICODE)
 target_link_libraries(rapps uuid)
-
-add_importlibs(rapps advapi32 comctl32 gdi32 urlmon user32 shell32 shlwapi kernel32 msvcrt ntdll)
+add_importlibs(rapps advapi32 comctl32 gdi32 urlmon user32 shell32 shlwapi ole32 msvcrt kernel32 ntdll)
 add_dependencies(rapps rappsmsg)
-add_message_headers(rappsmsg.mc)
+add_message_headers(ANSI rappsmsg.mc)
 add_cd_file(TARGET rapps DESTINATION reactos/system32 FOR all)