[GLU32]
[reactos.git] / reactos / dll / opengl / glu32 / CMakeLists.txt
index bb874f6..4c15d12 100644 (file)
@@ -114,6 +114,11 @@ set_module_type(glu32 win32dll)
 
 if(NOT MSVC)
     add_target_compile_flags(glu32 "-Wno-write-strings -Wno-unused-but-set-variable")
+    if(CMAKE_C_COMPILER_ID STREQUAL "Clang")
+        target_link_libraries(glu32 mingwex)
+        #FIXME: longjmp exists in both our msvcrt and mingwex
+        add_target_link_flags(glu32 "-Wl,--allow-multiple-definition")
+    endif()
 endif()
 
 add_importlibs(glu32 opengl32 gdi32 msvcrt kernel32 ntdll)