[CMAKE]
[reactos.git] / reactos / dll / win32 / browseui / CMakeLists.txt
index e5f39bc..2c1e04c 100644 (file)
@@ -60,7 +60,9 @@ add_pch(browseui precomp.h SOURCE)
 add_cd_file(TARGET browseui DESTINATION reactos/system32 FOR all)
 
 if(NOT MSVC)
-    add_target_compile_flags(browseui "-Wno-unused-but-set-variable")
+    if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
+        add_target_compile_flags(browseui "-Wno-unused-but-set-variable")
+    endif()
 
     # Binutils linker bug
     if(LTCG)