[STLPORT]
[reactos.git] / reactos / dll / win32 / glu32 / CMakeLists.txt
index 4c30e8f..a40bee4 100644 (file)
@@ -1,4 +1,8 @@
 
+if(NOT MSVC)
+    set_cpp()
+endif()
+
 add_definitions(
     -DRESOLVE_3D_TEXTURE_SUPPORT
     -DBUILD_GL32
@@ -107,12 +111,8 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/glu32.def)
 
 add_library(glu32 SHARED ${SOURCE})
-
-set_entrypoint(glu32 0)
-
-if(NOT MSVC)
-    target_link_libraries(glu32 stlport -lsupc++ -lgcc -lmingw32 oldnames)
-endif()
+allow_warnings(glu32)
+set_module_type(glu32 win32dll ENTRYPOINT 0 )
 
 add_importlibs(glu32
     opengl32
@@ -121,6 +121,5 @@ add_importlibs(glu32
     kernel32
     ntdll)
 
-add_pch(glu32 include/gluos.h)
 add_cd_file(TARGET glu32 DESTINATION reactos/system32 FOR all)
 add_importlib_target(glu32.spec)