[ICMP][IPHLPAPI] Move the icmp functions to iphlpapi where they belong. Brought to...
[reactos.git] / reactos / dll / win32 / iphlpapi / CMakeLists.txt
index 11cc683..32ad970 100644 (file)
@@ -10,6 +10,7 @@ add_definitions(-DGetAdaptersAddressesV2)
 list(APPEND SOURCE
     address.c
     dhcp_reactos.c
+    icmp.c
     ifenum_reactos.c
     ipstats_reactos.c
     iphlpapi_reactos.c
@@ -28,6 +29,6 @@ add_library(iphlpapi SHARED
 
 set_module_type(iphlpapi win32dll UNICODE)
 target_link_libraries(iphlpapi wine tdilib)
-add_importlibs(iphlpapi icmp dhcpcsvc advapi32 ws2_32 msvcrt kernel32 ntdll)
+add_importlibs(iphlpapi dhcpcsvc advapi32 ws2_32 msvcrt kernel32 ntdll)
 add_pch(iphlpapi iphlpapi_private.h SOURCE)
 add_cd_file(TARGET iphlpapi DESTINATION reactos/system32 FOR all)