[CMAKE]
[reactos.git] / reactos / dll / win32 / msvcrt20 / CMakeLists.txt
index dc114a5..707170e 100644 (file)
@@ -1,4 +1,5 @@
 
+include_directories(${REACTOS_SOURCE_DIR}/lib/sdk/crt/include)
 spec2def(msvcrt20.dll msvcrt20.spec)
 
 add_definitions(
@@ -11,8 +12,6 @@ add_definitions(
     -DCRTDLL
     -D__MINGW_IMPORT="")
 
-include_directories(${REACTOS_SOURCE_DIR}/lib/sdk/crt/include)
-
 list(APPEND SOURCE
     msvcrt20.c
     stubs.c
@@ -21,9 +20,7 @@ list(APPEND SOURCE
 
 add_library(msvcrt20 SHARED ${SOURCE})
 set_module_type(msvcrt20 win32dll ENTRYPOINT DllMain 12)
-
 add_dependencies(msvcrt20 psdk)
-
 target_link_libraries(msvcrt20 crt wine ${PSEH_LIB})
 
 if(MSVC)
@@ -32,5 +29,4 @@ if(MSVC)
 endif()
 
 add_importlibs(msvcrt20 kernel32 ntdll)
-
 add_cd_file(TARGET msvcrt20 DESTINATION reactos/system32 FOR all)