[ATL][SHELL32] Add basic support for _ATL_NO_EXCEPTIONS in CString, use it in shell32...
[reactos.git] / reactos / dll / win32 / shell32 / CMakeLists.txt
index 468cddf..7acb71f 100644 (file)
@@ -17,7 +17,8 @@ add_definitions(-D_WIN32_WINNT=0x600)
 
 add_definitions(
     -D_SHELL32_
-    -D_WINE)
+    -D_WINE
+    -D_ATL_NO_EXCEPTIONS)
 
 include_directories(
     ${REACTOS_SOURCE_DIR}/sdk/lib/atl
@@ -53,7 +54,9 @@ list(APPEND SOURCE
     folders/CFontsFolder.cpp
     folders/CControlPanelFolder.cpp
     folders/CRecycleBin.cpp
+    folders/CRegFolder.cpp
     droptargets/CexeDropHandler.cpp
+    droptargets/CFSDropTarget.cpp
     shlexec.cpp
     shlfileop.cpp
     shlfolder.cpp
@@ -104,5 +107,6 @@ set_module_type(shell32 win32dll UNICODE)
 target_link_libraries(shell32 shellmenu shelldesktop atlnew wine uuid recyclebin)
 add_delay_importlibs(shell32 uxtheme ole32 oleaut32 userenv version fmifs)
 add_importlibs(shell32 advapi32 browseui gdi32 user32 powrprof comctl32 comdlg32 shdocvw shlwapi devmgr winspool winmm mpr msvcrt kernel32 ntdll)
+add_dependencies(shell32 stdole2) # shell32_shldisp.tlb needs stdole2.tlb
 add_pch(shell32 precomp.h SOURCE)
 add_cd_file(TARGET shell32 DESTINATION reactos/system32 FOR all)