[CMAKE]
[reactos.git] / reactos / dll / win32 / wlanapi / CMakeLists.txt
index 8c356b0..233b303 100644 (file)
@@ -1,8 +1,6 @@
 
 include_directories( ${REACTOS_SOURCE_DIR}/include/reactos/idl)
-
 add_rpc_files(client ${REACTOS_SOURCE_DIR}/include/reactos/idl/wlansvc.idl)
-
 spec2def(wlanapi.dll wlanapi.spec ADD_IMPORTLIB)
 
 list(APPEND SOURCE
@@ -12,15 +10,7 @@ list(APPEND SOURCE
     ${CMAKE_CURRENT_BINARY_DIR}/wlansvc_c.c)
 
 add_library(wlanapi SHARED ${SOURCE})
-
 set_module_type(wlanapi win32dll)
-
-target_link_libraries(wlanapi
-    wine
-    ${PSEH_LIB})
-
+target_link_libraries(wlanapi wine ${PSEH_LIB})
 add_importlibs(wlanapi rpcrt4 msvcrt kernel32 ntdll)
-
-
-add_dependencies(wlanapi psdk)
 add_cd_file(TARGET wlanapi DESTINATION reactos/system32 FOR all)