[FRAMEBUF_NEW]
[reactos.git] / reactos / win32ss / drivers / displays / framebuf_new / CMakeLists.txt
index 861778d..922a6a6 100644 (file)
@@ -14,9 +14,7 @@ add_library(framebuf_new SHARED
     framebuf_new.rc
     ${CMAKE_CURRENT_BINARY_DIR}/framebuf_new.def)
 
-set_entrypoint(framebuf_new DrvEnableDriver 12)
-set_subsystem(framebuf_new native)
-set_image_base(framebuf_new 0x00010000)
+set_module_type(framebuf_new kerneldll ENTRYPOINT DrvEnableDriver 12)
 target_link_libraries(framebuf_new libcntpr)
 add_importlibs(framebuf_new win32k)
 add_pch(framebuf_new driver.h SOURCE)