[SPOOLSS]
[reactos.git] / reactos / win32ss / printing / base / spoolss / spoolss.spec
index e2685d9..4fcd3be 100644 (file)
@@ -1,7 +1,7 @@
 @ stub AbortPrinter
 @ stub AddDriverCatalog
 @ stub AddFormW
-@ stub AddJobW
+@ stdcall AddJobW(long long ptr long ptr)
 @ stub AddMonitorW
 @ stub AddPerMachineConnectionW
 @ stub AddPortExW
@@ -17,7 +17,7 @@
 @ stub AdjustPointersInStructuresArray
 @ stub AlignKMPtr
 @ stub AlignRpcPtr
-@ stub AllocSplStr
+@ stdcall AllocSplStr(ptr)
 @ stub AllowRemoteCalls
 @ stub AppendPrinterNotifyInfoData
 @ stub bGetDevModePerUser
@@ -53,9 +53,9 @@
 @ stub DeletePrinterKeyW
 @ stub DeletePrintProcessorW
 @ stub DeletePrintProvidorW
-@ stub DllAllocSplMem
-@ stub DllFreeSplMem
-@ stub DllFreeSplStr
+@ stdcall DllAllocSplMem(long)
+@ stdcall DllFreeSplMem(ptr)
+@ stdcall DllFreeSplStr(ptr)
 @ stdcall EndDocPrinter(long)
 @ stdcall EndPagePrinter(long)
 @ stub EnumFormsW
@@ -68,8 +68,8 @@
 @ stub EnumPrinterDriversW
 @ stub EnumPrinterKeyW
 @ stdcall EnumPrintersW(long ptr long ptr long ptr ptr)
-@ stub EnumPrintProcessorDatatypesW
-@ stub EnumPrintProcessorsW
+@ stdcall EnumPrintProcessorDatatypesW(ptr ptr long ptr long ptr ptr)
+@ stdcall EnumPrintProcessorsW(ptr ptr long ptr long ptr ptr)
 @ stub FindClosePrinterChangeNotification
 @ stub FlushPrinter
 @ stub FormatPrinterForRegistryKey
@@ -78,7 +78,7 @@
 @ stub GetClientUserHandle
 @ stub GetFormW
 @ stub GetJobAttributes
-@ stub GetJobW
+@ stdcall GetJobW(long long long ptr long ptr)
 @ stub GetNetworkId
 @ stub GetPrinterDataExW
 @ stub GetPrinterDataW
@@ -96,7 +96,7 @@
 @ stub LoadDriverFiletoConvertDevmode
 @ stub LoadDriverWithVersion
 @ stub LogWmiTraceEvent
-@ stub MarshallDownStructure
+@ stdcall MarshallDownStructure(ptr ptr long long)
 @ stub MarshallDownStructuresArray
 @ stub MarshallUpStructure
 @ stub MarshallUpStructuresArray
 @ stub OpenPrinterExW
 @ stub OpenPrinterPortW
 @ stdcall OpenPrinterW(wstr ptr ptr)
-@ stub PackStrings
+@ stdcall PackStrings(ptr ptr ptr ptr)
 @ stub PartialReplyPrinterChangeNotification
 @ stub PlayGdiScriptOnPrinterIC
 @ stub PrinterHandleRundown
 @ stub ProvidorFindFirstPrinterChangeNotification
 @ stub pszDbgAllocMsgA
 @ stub ReadPrinter
-@ stub ReallocSplMem
-@ stub ReallocSplStr
+@ stdcall ReallocSplMem(ptr long long)
+@ stdcall ReallocSplStr(ptr ptr)
 @ stub RemoteFindFirstPrinterChangeNotification
 @ stub ReplyClosePrinter
 @ stub ReplyOpenPrinter
 @ stub SplCommitSpoolData
 @ stub SplDriverUnloadComplete
 @ stub SplGetSpoolFileInfo
-@ stub SplInitializeWinSpoolDrv
+@ stdcall SplInitializeWinSpoolDrv(ptr)
 @ stub SplIsSessionZero
-@ stub SplIsUpgrade
+@ stdcall SplIsUpgrade()
 @ stub SplPowerEvent
 @ stub SplProcessPnPEvent
 @ stub SplPromptUIInUsersSession