[SPOOLSS]
[reactos.git] / reactos / win32ss / printing / base / spoolss / spoolss.spec
index 7e10f88..5c0892c 100644 (file)
@@ -1,7 +1,7 @@
 @ stub AbortPrinter
 @ stub AddDriverCatalog
 @ stub AddFormW
-@ stub AddJobW
+@ stdcall AddJobW(long long ptr long ptr)
 @ stub AddMonitorW
 @ stub AddPerMachineConnectionW
 @ stub AddPortExW
@@ -16,8 +16,8 @@
 @ stub AdjustPointers
 @ stub AdjustPointersInStructuresArray
 @ stub AlignKMPtr
-@ stub AlignRpcPtr
-@ stub AllocSplStr
+@ stdcall AlignRpcPtr(ptr ptr)
+@ stdcall AllocSplStr(ptr)
 @ stub AllowRemoteCalls
 @ stub AppendPrinterNotifyInfoData
 @ stub bGetDevModePerUser
 @ stub DeletePrinterKeyW
 @ stub DeletePrintProcessorW
 @ stub DeletePrintProvidorW
-@ stub DllAllocSplMem
-@ stub DllFreeSplMem
-@ stub DllFreeSplStr
+@ stdcall DllAllocSplMem(long)
+@ stdcall DllFreeSplMem(ptr)
+@ stdcall DllFreeSplStr(ptr)
 @ stdcall EndDocPrinter(long)
 @ stdcall EndPagePrinter(long)
 @ stub EnumFormsW
-@ stub EnumJobsW
-@ stub EnumMonitorsW
+@ stdcall EnumJobsW(long long long long ptr long ptr ptr)
+@ stdcall EnumMonitorsW(wstr long ptr long ptr ptr)
 @ stub EnumPerMachineConnectionsW
-@ stub EnumPortsW
+@ stdcall EnumPortsW(wstr long ptr long ptr ptr)
 @ stub EnumPrinterDataExW
 @ stub EnumPrinterDataW
 @ stub EnumPrinterDriversW
 @ stub EnumPrinterKeyW
-@ stdcall EnumPrintersW(long ptr long ptr long ptr ptr)
-@ stub EnumPrintProcessorDatatypesW
-@ stub EnumPrintProcessorsW
+@ stdcall EnumPrintersW(long wstr long ptr long ptr ptr)
+@ stdcall EnumPrintProcessorDatatypesW(wstr wstr long ptr long ptr ptr)
+@ stdcall EnumPrintProcessorsW(wstr wstr long ptr long ptr ptr)
 @ stub FindClosePrinterChangeNotification
 @ stub FlushPrinter
 @ stub FormatPrinterForRegistryKey
@@ -78,7 +78,7 @@
 @ stub GetClientUserHandle
 @ stub GetFormW
 @ stub GetJobAttributes
-@ stub GetJobW
+@ stdcall GetJobW(long long long ptr long ptr)
 @ stub GetNetworkId
 @ stub GetPrinterDataExW
 @ stub GetPrinterDataW
 @ stdcall GetPrintProcessorDirectoryW(wstr wstr long ptr long ptr)
 @ stub GetServerPolicy
 @ stub GetShrinkedSize
-@ stub ImpersonatePrinterClient
+@ stdcall ImpersonatePrinterClient(long)
 @ stdcall InitializeRouter(long)
 @ stub IsNamedPipeRpcCall
 @ stub LoadDriver
 @ stub LoadDriverFiletoConvertDevmode
 @ stub LoadDriverWithVersion
 @ stub LogWmiTraceEvent
-@ stub MarshallDownStructure
+@ stdcall MarshallDownStructure(ptr ptr long long)
 @ stub MarshallDownStructuresArray
 @ stub MarshallUpStructure
 @ stub MarshallUpStructuresArray
 @ stub OpenPrinterExW
 @ stub OpenPrinterPortW
 @ stdcall OpenPrinterW(wstr ptr ptr)
-@ stub PackStrings
+@ stdcall PackStrings(ptr ptr ptr ptr)
 @ stub PartialReplyPrinterChangeNotification
 @ stub PlayGdiScriptOnPrinterIC
 @ stub PrinterHandleRundown
 @ stub ProvidorFindClosePrinterChangeNotification
 @ stub ProvidorFindFirstPrinterChangeNotification
 @ stub pszDbgAllocMsgA
-@ stub ReadPrinter
-@ stub ReallocSplMem
-@ stub ReallocSplStr
+@ stdcall ReadPrinter(long ptr long ptr)
+@ stdcall ReallocSplMem(ptr long long)
+@ stdcall ReallocSplStr(ptr ptr)
 @ stub RemoteFindFirstPrinterChangeNotification
 @ stub ReplyClosePrinter
 @ stub ReplyOpenPrinter
 @ stub ReplyPrinterChangeNotification
 @ stub ResetPrinterW
-@ stub RevertToPrinterSelf
+@ stdcall RevertToPrinterSelf()
 @ stub RouterAllocBidiMem
 @ stub RouterAllocBidiResponseContainer
 @ stub RouterAllocPrinterNotifyInfo
 @ stub RouterFreePrinterNotifyInfo
 @ stub RouterRefreshPrinterChangeNotification
 @ stub RouterReplyPrinter
-@ stub ScheduleJob
+@ stdcall ScheduleJob(long long)
 @ stub SeekPrinter
 @ stub SendRecvBidiData
 @ stub SetAllocFailCount
 @ stub SetFormW
-@ stub SetJobW
+@ stdcall SetJobW(long long long ptr long)
 @ stub SetPortW
 @ stub SetPrinterDataExW
 @ stub SetPrinterDataW
 @ stub SplCommitSpoolData
 @ stub SplDriverUnloadComplete
 @ stub SplGetSpoolFileInfo
-@ stub SplInitializeWinSpoolDrv
+@ stdcall SplInitializeWinSpoolDrv(ptr)
 @ stub SplIsSessionZero
-@ stub SplIsUpgrade
+@ stdcall SplIsUpgrade()
 @ stub SplPowerEvent
 @ stub SplProcessPnPEvent
 @ stub SplPromptUIInUsersSession
 @ stub SpoolerFindNextPrinterChangeNotification
 @ stub SpoolerFreePrinterNotifyInfo
 @ stub SpoolerHasInitialized
-@ stub SpoolerInit
+@ stdcall SpoolerInit()
 @ stdcall StartDocPrinterW(long long ptr)
 @ stdcall StartPagePrinter(long)
 @ stub UndoAlignKMPtr
-@ stub UndoAlignRpcPtr
+@ stdcall UndoAlignRpcPtr(ptr ptr long ptr)
 @ stub UnloadDriver
 @ stub UnloadDriverFile
 @ stub UpdateBufferSize