[GDI32_APITEST] Add tests for GetFontResourceInfoW. Patch by Katayama Hirofumi MZ...
[reactos.git] / rostests / apitests / gdi32 / CMakeLists.txt
index d63a183..7c593eb 100644 (file)
@@ -1,5 +1,4 @@
 
-add_definitions(-D_DLL -D__USE_CRTIMP)
 include_directories(${REACTOS_SOURCE_DIR}/win32ss)
 
 list(APPEND SOURCE
@@ -23,7 +22,11 @@ list(APPEND SOURCE
     EngCreateSemaphore.c
     EngDeleteSemaphore.c
     EngReleaseSemaphore.c
+    EnumFontFamilies.c
+    ExcludeClipRect.c
     ExtCreatePen.c
+    ExtCreateRegion.c
+    FrameRgn.c
     GdiConvertBitmap.c
     GdiConvertBrush.c
     GdiConvertDC.c
@@ -36,10 +39,13 @@ list(APPEND SOURCE
     GdiGetLocalDC.c
     GdiReleaseLocalDC.c
     GdiSetAttrs.c
+    GetClipBox.c
     GetClipRgn.c
     GetCurrentObject.c
     GetDIBColorTable.c
     GetDIBits.c
+    GetFontResourceInfoW.c
+    GetGlyphIndices.c
     GetObject.c
     GetRandomRgn.c
     GetPixel.c
@@ -47,9 +53,15 @@ list(APPEND SOURCE
     GetTextExtentExPoint.c
     GetTextFace.c
     MaskBlt.c
+    NtGdiAddFontResource.c
+    OffsetClipRgn.c
+    OffsetRgn.c
+    PaintRgn.c
     PatBlt.c
     Rectangle.c
+    RealizePalette.c
     SelectObject.c
+    SetBoundsRect.c
     SetBrushOrgEx.c
     SetDCPenColor.c
     SetDIBits.c
@@ -62,14 +74,8 @@ list(APPEND SOURCE
     init.c
     testlist.c)
 
-if(NOT MSVC)
-    # FIXME: http://www.cmake.org/Bug/view.php?id=12998
-    #allow_warnings(gdi32_apitest)
-    set_source_files_properties(${SOURCE} PROPERTIES COMPILE_FLAGS "-Wno-error")
-endif()
-
-add_executable(gdi32_apitest ${SOURCE})
-target_link_libraries(gdi32_apitest wine ${PSEH_LIB})
+add_executable(gdi32_apitest ${SOURCE} resource.rc)
+target_link_libraries(gdi32_apitest ${PSEH_LIB} win32ksys)
 set_module_type(gdi32_apitest win32cui)
 add_importlibs(gdi32_apitest gdi32 user32 msvcrt kernel32 ntdll)
-add_cd_file(TARGET gdi32_apitest DESTINATION reactos/bin FOR all)
+add_rostests_file(TARGET gdi32_apitest)