[NTDLL_APITEST] Add tests for RtlpEnsureBufferSize. CORE-11990
[reactos.git] / rostests / apitests / ntdll / CMakeLists.txt
index 4eab1e6..538261f 100644 (file)
@@ -28,6 +28,7 @@ list(APPEND SOURCE
     RtlDeleteAce.c
     RtlDetermineDosPathNameType.c
     RtlDoesFileExists.c
+    RtlDosApplyFileIsolationRedirection_Ustr.c
     RtlDosPathNameToNtPathName_U.c
     RtlDosSearchPath_U.c
     RtlDosSearchPath_Ustr.c
@@ -40,8 +41,11 @@ list(APPEND SOURCE
     RtlGetLongestNtPathLength.c
     RtlImageRvaToVa.c
     RtlInitializeBitMap.c
+    RtlIsNameLegalDOS8Dot3.c
     RtlMemoryStream.c
+    RtlpEnsureBufferSize.c
     RtlReAllocateHeap.c
+    RtlUpcaseUnicodeStringToCountedOemString.c
     StackOverflow.c
     SystemInfo.c
     Timer.c
@@ -60,4 +64,9 @@ if(NOT MSVC)
     set_source_files_properties(RtlGetFullPathName_UstrEx.c PROPERTIES COMPILE_FLAGS "-Wno-format")
 endif()
 
-add_cd_file(TARGET ntdll_apitest DESTINATION reactos/bin FOR all)
+add_rostests_file(TARGET ntdll_apitest)
+add_rostests_file(TARGET ntdll_apitest SUBDIR testdata)
+# These are empty files
+add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/ntdll_apitest.exe.local" SUBDIR testdata)
+add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/shell32.dll" SUBDIR testdata)
+add_rostests_file(FILE "${CMAKE_CURRENT_SOURCE_DIR}/test.dll" SUBDIR testdata)