[WIN32U] Rename win32kdll to win32u, which is the "official" name on Windows 10
[reactos.git] / rostests / apitests / win32u / win32u_ros / CMakeLists.txt
diff --git a/rostests/apitests/win32u/win32u_ros/CMakeLists.txt b/rostests/apitests/win32u/win32u_ros/CMakeLists.txt
new file mode 100644 (file)
index 0000000..15e8d2a
--- /dev/null
@@ -0,0 +1,14 @@
+
+include_directories(${REACTOS_SOURCE_DIR}/win32ss)
+
+spec2def(win32u.dll win32u_ros.spec ADD_IMPORTLIB)
+add_asm_files(win32u_ros_asm sys-stubs.S)
+
+add_library(win32u SHARED 
+    main.c
+    ${win32u_ros_asm}
+    ${CMAKE_CURRENT_BINARY_DIR}/win32u.def)
+
+set_module_type(win32u module)
+add_dependencies(win32u psdk)
+add_rostests_file(TARGET win32u)