Git conversion: Make reactos the root directory, move rosapps, rostests, wallpapers...
[reactos.git] / sdk / lib / inflib / CMakeLists.txt
diff --git a/sdk/lib/inflib/CMakeLists.txt b/sdk/lib/inflib/CMakeLists.txt
new file mode 100644 (file)
index 0000000..e6ed96f
--- /dev/null
@@ -0,0 +1,32 @@
+
+list(APPEND SOURCE
+    infcore.c
+    infget.c
+    infput.c)
+
+if(CMAKE_CROSSCOMPILING)
+    list(APPEND SOURCE
+        infrosgen.c
+        infrosget.c
+        infrosput.c
+        inflib.h)
+
+    add_library(inflib ${SOURCE})
+    add_pch(inflib inflib.h SOURCE)
+    add_dependencies(inflib psdk)
+else()
+    list(APPEND SOURCE
+        infhostgen.c
+        infhostget.c
+        infhostput.c
+        infhostrtl.c)
+
+    add_definitions(-D__NO_CTYPE_INLINES -DINFLIB_HOST)
+    add_library(inflibhost ${SOURCE})
+
+    if(NOT MSVC)
+        add_target_compile_flags(inflibhost "-fshort-wchar -Wpointer-arith -Wwrite-strings")
+    endif()
+
+    target_link_libraries(inflibhost unicode)
+endif()