[MKISOFS] Silence MSVC warnings
[reactos.git] / sdk / tools / mkisofs / CMakeLists.txt
index 37d85bc..a045c03 100644 (file)
@@ -1,7 +1,7 @@
 
 add_definitions(
     -DDUPLICATES_ONCE
-    -DINS_BASE="\\".\\""
+    -DINS_BASE="\\\".\\\""
     -DSCHILY_BUILD
     -DSORTING)
 
@@ -84,6 +84,11 @@ if(MSVC)
     # mkisofs uses K&R-style function definitions to support very old compilers.
     # MSVC complains about the resulting foo() vs. foo(void) mismatches.
     add_target_compile_flags(mkisofs "/wd4113")
+
+    if (ARCH STREQUAL "amd64")
+        # Disable warning "conversion from 'size_t' to 'int', possible loss of data"
+        add_target_compile_flags(mkisofs "/wd4267")
+    endif()
 else()
     # libschily implements an own printf function with support for the %r formatter.
     # Silence compilers checking for invalid formatting sequences.