Sync with trunk r58033.
[reactos.git] / win32ss / user / user32 / CMakeLists.txt
index d7bfe86..537682f 100644 (file)
@@ -7,8 +7,6 @@ include_directories(
     include
     ${REACTOS_SOURCE_DIR}/win32ss/include)
 
-set_rc_compiler()
-
 list(APPEND SOURCE
     controls/appswitch.c
     controls/button.c
@@ -71,16 +69,8 @@ else()
 endif()
 
 add_library(user32 SHARED ${SOURCE})
-set_module_type(user32
-    win32dll
-    ENTRYPOINT DllMain 12
-    UNICODE)
-
-target_link_libraries(user32
-    user32_wsprintf
-    wine
-    win32ksys
-    ${PSEH_LIB})
+set_module_type(user32 win32dll ENTRYPOINT DllMain 12 UNICODE)
+target_link_libraries(user32 user32_wsprintf wine win32ksys ${PSEH_LIB})
 
 if(MSVC)
     # for __ftol2_sse, float to int cast helper
@@ -91,4 +81,3 @@ add_delay_importlibs(user32 imm32 usp10)
 add_importlibs(user32 gdi32 advapi32 kernel32 ntdll)
 add_pch(user32 include/user32.h)
 add_cd_file(TARGET user32 DESTINATION reactos/system32 FOR all)
-