Synchronize with trunk r58457.
[reactos.git] / lib / 3rdparty / libxml2 / libxml2.spec
1 Summary: Library providing XML and HTML support
2 Name: libxml2
3 Version: 2.9.0
4 Release: 1
5 License: MIT
6 Group: Development/Libraries
7 Source: ftp://xmlsoft.org/libxml2/libxml2-%{version}.tar.gz
8 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
9 BuildRequires: python python-devel zlib-devel pkgconfig xz-devel
10 URL: http://xmlsoft.org/
11
12 %description
13 This library allows to manipulate XML files. It includes support
14 to read, modify and write XML and HTML files. There is DTDs support
15 this includes parsing and validation even with complex DtDs, either
16 at parse time or later once the document has been modified. The output
17 can be a simple SAX stream or and in-memory DOM like representations.
18 In this case one can use the built-in XPath and XPointer implementation
19 to select subnodes or ranges. A flexible Input/Output mechanism is
20 available, with existing HTTP and FTP modules and combined to an
21 URI library.
22
23 %package devel
24 Summary: Libraries, includes, etc. to develop XML and HTML applications
25 Group: Development/Libraries
26 Requires: libxml2 = %{version}-%{release}
27 Requires: zlib-devel
28 Requires: xz-devel
29 Requires: pkgconfig
30
31 %description devel
32 Libraries, include files, etc you can use to develop XML applications.
33 This library allows to manipulate XML files. It includes support
34 to read, modify and write XML and HTML files. There is DTDs support
35 this includes parsing and validation even with complex DtDs, either
36 at parse time or later once the document has been modified. The output
37 can be a simple SAX stream or and in-memory DOM like representations.
38 In this case one can use the built-in XPath and XPointer implementation
39 to select subnodes or ranges. A flexible Input/Output mechanism is
40 available, with existing HTTP and FTP modules and combined to an
41 URI library.
42
43 %package python
44 Summary: Python bindings for the libxml2 library
45 Group: Development/Libraries
46 Requires: libxml2 = %{version}-%{release}
47 Requires: python
48
49 %description python
50 The libxml2-python package contains a module that permits applications
51 written in the Python programming language to use the interface
52 supplied by the libxml2 library to manipulate XML files.
53
54 This library allows to manipulate XML files. It includes support
55 to read, modify and write XML and HTML files. There is DTDs support
56 this includes parsing and validation even with complex DTDs, either
57 at parse time or later once the document has been modified.
58
59 %prep
60 %setup -q
61
62 %build
63 %configure
64 make %{_smp_mflags}
65 gzip -9 ChangeLog
66
67 %install
68 rm -fr %{buildroot}
69
70 %makeinstall
71 (cd doc/examples ; make clean ; rm -rf .deps Makefile)
72 gzip -9 doc/libxml2-api.xml
73 rm -f $RPM_BUILD_ROOT%{_libdir}/*.la
74
75 %clean
76 rm -fr %{buildroot}
77
78 %post
79 /sbin/ldconfig
80
81 %postun
82 /sbin/ldconfig
83
84 %files
85 %defattr(-, root, root)
86
87 %doc AUTHORS ChangeLog.gz NEWS README Copyright TODO
88 %doc %{_mandir}/man1/xmllint.1*
89 %doc %{_mandir}/man1/xmlcatalog.1*
90 %doc %{_mandir}/man3/libxml.3*
91
92 %{_libdir}/lib*.so.*
93 %{_bindir}/xmllint
94 %{_bindir}/xmlcatalog
95
96 %files devel
97 %defattr(-, root, root)
98
99 %doc %{_mandir}/man1/xml2-config.1*
100 %doc AUTHORS ChangeLog.gz NEWS README Copyright
101 %doc doc/*.html doc/html doc/*.gif doc/*.png
102 %doc doc/tutorial doc/libxml2-api.xml.gz
103 %doc doc/examples
104 %doc %dir %{_datadir}/gtk-doc/html/libxml2
105 %doc %{_datadir}/gtk-doc/html/libxml2/*.devhelp
106 %doc %{_datadir}/gtk-doc/html/libxml2/*.html
107 %doc %{_datadir}/gtk-doc/html/libxml2/*.png
108 %doc %{_datadir}/gtk-doc/html/libxml2/*.css
109
110 %{_libdir}/lib*.so
111 %{_libdir}/*a
112 %{_libdir}/*.sh
113 %{_includedir}/*
114 %{_bindir}/xml2-config
115 %{_datadir}/aclocal/libxml.m4
116 %{_libdir}/pkgconfig/libxml-2.0.pc
117 %files python
118 %defattr(-, root, root)
119
120 %doc AUTHORS ChangeLog.gz NEWS README Copyright
121 %{_libdir}/python*/site-packages/libxml2.py*
122 %{_libdir}/python*/site-packages/drv_libxml2.py*
123 %{_libdir}/python*/site-packages/libxml2mod*
124 %doc python/TODO
125 %doc python/libxml2class.txt
126 %doc python/tests/*.py
127 %doc doc/*.py
128 %doc doc/python.html
129
130 %changelog
131 * Tue Sep 11 2012 Daniel Veillard <veillard@redhat.com>
132 - upstream release 2.9.0 see http://xmlsoft.org/news.html
133