_findnext is already implemented. Fixes a crash during Abiword startup
[reactos.git] / reactos / dll / win32 / msvcrt / msvcrt.spec
1 # msvcrt.dll - MS VC++ Run Time Library
2
3 @ cdecl $I10_OUTPUT() MSVCRT_I10_OUTPUT
4 @ cdecl -i386 -norelay ??0__non_rtti_object@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT___non_rtti_object_copy_ctor
5 @ cdecl -i386 -norelay ??0__non_rtti_object@@QAE@PBD@Z(ptr) __thiscall_MSVCRT___non_rtti_object_ctor
6 @ cdecl -i386 -norelay ??0bad_cast@@QAE@ABQBD@Z(ptr) __thiscall_MSVCRT_bad_cast_ctor
7 @ cdecl -i386 -norelay ??0bad_cast@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_cast_copy_ctor
8 @ cdecl -i386 -norelay ??0bad_typeid@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_typeid_copy_ctor
9 @ cdecl -i386 -norelay ??0bad_typeid@@QAE@PBD@Z(ptr) __thiscall_MSVCRT_bad_typeid_ctor
10 @ cdecl -i386 -norelay ??0exception@@QAE@ABQBD@Z(ptr) __thiscall_MSVCRT_exception_ctor
11 @ cdecl -i386 -norelay ??0exception@@QAE@ABV0@@Z(ptr) __thiscall_MSVCRT_exception_copy_ctor
12 @ cdecl -i386 -norelay ??0exception@@QAE@XZ() __thiscall_MSVCRT_exception_default_ctor
13 @ cdecl -i386 -norelay ??1__non_rtti_object@@UAE@XZ() __thiscall_MSVCRT___non_rtti_object_dtor
14 @ cdecl -i386 -norelay ??1bad_cast@@UAE@XZ() __thiscall_MSVCRT_bad_cast_dtor
15 @ cdecl -i386 -norelay ??1bad_typeid@@UAE@XZ() __thiscall_MSVCRT_bad_typeid_dtor
16 @ cdecl -i386 -norelay ??1exception@@UAE@XZ() __thiscall_MSVCRT_exception_dtor
17 @ cdecl -i386 -norelay ??1type_info@@UAE@XZ() __thiscall_MSVCRT_type_info_dtor
18 @ cdecl ??2@YAPAXI@Z(long) MSVCRT_operator_new
19 @ cdecl ??_U@YAPAXI@Z(long) MSVCRT_operator_new
20 @ cdecl ??3@YAXPAX@Z(ptr) MSVCRT_operator_delete
21 @ cdecl ??_V@YAXPAX@Z(ptr) MSVCRT_operator_delete
22 @ cdecl -i386 -norelay ??4__non_rtti_object@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT___non_rtti_object_opequals
23 @ cdecl -i386 -norelay ??4bad_cast@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_cast_opequals
24 @ cdecl -i386 -norelay ??4bad_typeid@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_bad_typeid_opequals
25 @ cdecl -i386 -norelay ??4exception@@QAEAAV0@ABV0@@Z(ptr) __thiscall_MSVCRT_exception_opequals
26 @ cdecl -i386 -norelay ??8type_info@@QBEHABV0@@Z(ptr) __thiscall_MSVCRT_type_info_opequals_equals
27 @ cdecl -i386 -norelay ??9type_info@@QBEHABV0@@Z(ptr) __thiscall_MSVCRT_type_info_opnot_equals
28 @ extern -i386 ??_7__non_rtti_object@@6B@ MSVCRT___non_rtti_object_vtable
29 @ extern -i386 ??_7bad_cast@@6B@ MSVCRT_bad_cast_vtable
30 @ extern -i386 ??_7bad_typeid@@6B@ MSVCRT_bad_typeid_vtable
31 @ extern -i386 ??_7exception@@6B@ MSVCRT_exception_vtable
32 @ cdecl -i386 -norelay ??_E__non_rtti_object@@UAEPAXI@Z(long) __thiscall_MSVCRT___non_rtti_object_vector_dtor
33 @ cdecl -i386 -norelay ??_Ebad_cast@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_cast_vector_dtor
34 @ cdecl -i386 -norelay ??_Ebad_typeid@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_typeid_vector_dtor
35 @ cdecl -i386 -norelay ??_Eexception@@UAEPAXI@Z(long) __thiscall_MSVCRT_exception_vector_dtor
36 @ cdecl -i386 -norelay ??_G__non_rtti_object@@UAEPAXI@Z(long) __thiscall_MSVCRT___non_rtti_object_scalar_dtor
37 @ cdecl -i386 -norelay ??_Gbad_cast@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_cast_scalar_dtor
38 @ cdecl -i386 -norelay ??_Gbad_typeid@@UAEPAXI@Z(long) __thiscall_MSVCRT_bad_typeid_scalar_dtor
39 @ cdecl -i386 -norelay ??_Gexception@@UAEPAXI@Z(long) __thiscall_MSVCRT_exception_scalar_dtor
40 @ cdecl ?_query_new_handler@@YAP6AHI@ZXZ() MSVCRT__query_new_handler
41 @ cdecl ?_query_new_mode@@YAHXZ() MSVCRT__query_new_mode
42 @ cdecl ?_set_new_handler@@YAP6AHI@ZP6AHI@Z@Z(ptr) MSVCRT__set_new_handler
43 @ cdecl ?_set_new_mode@@YAHH@Z(long) MSVCRT__set_new_mode
44 @ cdecl ?_set_se_translator@@YAP6AXIPAU_EXCEPTION_POINTERS@@@ZP6AXI0@Z@Z(ptr) MSVCRT__set_se_translator
45 @ cdecl -i386 -norelay ?before@type_info@@QBEHABV1@@Z(ptr) __thiscall_MSVCRT_type_info_before
46 @ cdecl -i386 -norelay ?name@type_info@@QBEPBDXZ() __thiscall_MSVCRT_type_info_name
47 @ cdecl -i386 -norelay ?raw_name@type_info@@QBEPBDXZ() __thiscall_MSVCRT_type_info_raw_name
48 @ cdecl ?set_new_handler@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT__set_new_handler
49 @ cdecl ?set_terminate@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT_set_terminate
50 @ cdecl ?set_unexpected@@YAP6AXXZP6AXXZ@Z(ptr) MSVCRT_set_unexpected
51 @ cdecl ?terminate@@YAXXZ() MSVCRT_terminate
52 @ cdecl ?unexpected@@YAXXZ() MSVCRT_unexpected
53 @ cdecl -i386 -norelay ?what@exception@@UBEPBDXZ() __thiscall_MSVCRT_what_exception
54 @ cdecl _CIacos()
55 @ cdecl _CIasin()
56 @ cdecl _CIatan()
57 @ cdecl _CIatan2()
58 @ cdecl _CIcos()
59 @ cdecl _CIcosh()
60 @ cdecl _CIexp()
61 @ cdecl _CIfmod()
62 @ cdecl _CIlog()
63 @ cdecl _CIlog10()
64 @ cdecl _CIpow()
65 @ cdecl _CIsin()
66 @ cdecl _CIsinh()
67 @ cdecl _CIsqrt()
68 @ cdecl _CItan()
69 @ cdecl _CItanh()
70 @ cdecl _CxxThrowException(long long)
71 @ cdecl -i386 -norelay _EH_prolog()
72 @ cdecl _Getdays()
73 @ cdecl _Getmonths()
74 @ cdecl _Gettnames()
75 @ extern _HUGE
76 @ cdecl _Strftime(str long str ptr ptr)
77 @ cdecl _XcptFilter(long ptr)
78 @ cdecl -i386 -norelay __CxxFrameHandler(ptr ptr ptr ptr)
79 @ stdcall -i386 __CxxLongjmpUnwind(ptr)
80 @ cdecl __RTCastToVoid(ptr) MSVCRT___RTCastToVoid
81 @ cdecl __RTDynamicCast(ptr long ptr ptr long) MSVCRT___RTDynamicCast
82 @ cdecl __RTtypeid(ptr) MSVCRT___RTtypeid
83 @ stub __STRINGTOLD #(ptr ptr str long)
84 @ extern __argc
85 @ extern __argv
86 @ extern __badioinfo
87 @ cdecl __crtCompareStringA(long long str long str long)
88 @ stub __crtCompareStringW #(long long wstr long wstr long)
89 @ cdecl __crtGetLocaleInfoW(long long ptr long)
90 @ cdecl __crtLCMapStringA(long long str long ptr long long long)
91 @ cdecl __dllonexit(ptr ptr ptr)
92 @ cdecl __doserrno()
93 @ cdecl __fpecode()
94 @ stub __get_app_type
95 @ cdecl __getmainargs(ptr ptr ptr long ptr)
96 @ extern __initenv
97 @ cdecl __isascii(long) ntdll.__isascii
98 @ cdecl __iscsym(long) ntdll.__iscsym
99 @ cdecl __iscsymf(long) ntdll.__iscsymf
100 @ extern __lc_codepage
101 @ stub __lc_collate
102 @ extern __lc_collate_cp
103 @ extern __lc_handle
104 @ cdecl __lconv_init()
105 @ extern __mb_cur_max
106 @ cdecl __p___argc()
107 @ cdecl __p___argv()
108 @ cdecl __p___initenv()
109 @ cdecl __p___mb_cur_max()
110 @ cdecl __p___wargv()
111 @ cdecl __p___winitenv()
112 @ cdecl __p__acmdln()
113 @ cdecl __p__amblksiz()
114 @ cdecl __p__commode()
115 @ cdecl __p__daylight()
116 @ cdecl __p__dstbias()
117 @ cdecl __p__environ()
118 @ stub __p__fileinfo #()
119 @ cdecl __p__fmode()
120 @ cdecl __p__iob()
121 @ stub __p__mbcasemap #()
122 @ cdecl __p__mbctype() _mbctype
123 @ cdecl __p__osver()
124 @ cdecl __p__pctype()
125 @ cdecl __p__pgmptr()
126 @ stub __p__pwctype #()
127 @ cdecl __p__timezone()
128 @ cdecl __p__tzname() _tzname
129 @ cdecl __p__wcmdln()
130 @ cdecl __p__wenviron()
131 @ cdecl __p__winmajor()
132 @ cdecl __p__winminor()
133 @ cdecl __p__winver()
134 @ cdecl __p__wpgmptr()
135 @ extern __pioinfo
136 @ stub __pxcptinfoptrs #()
137 @ cdecl __set_app_type(long)
138 @ extern __setlc_active
139 @ cdecl __setusermatherr(ptr)
140 @ cdecl __threadhandle()
141 @ cdecl __threadid()
142 @ cdecl __toascii(long) ntdll.__toascii
143 @ cdecl __unDName(ptr str long ptr ptr long)
144 @ cdecl __unDNameEx(ptr str long ptr ptr ptr long)
145 @ extern __unguarded_readlc_active
146 @ extern __wargv
147 @ cdecl __wgetmainargs(ptr ptr ptr long ptr)
148 @ extern __winitenv
149 @ cdecl _abnormal_termination()
150 @ cdecl _access(str long)
151 @ extern _acmdln
152 @ stub _adj_fdiv_m16i #stdcall _adj_fdiv_m16i(long)
153 @ stdcall _adj_fdiv_m32(long)
154 @ stdcall _adj_fdiv_m32i(long)
155 @ stdcall _adj_fdiv_m64(double)
156 @ cdecl _adj_fdiv_r()
157 @ stub _adj_fdivr_m16i #stdcall _adj_fdivr_m16i(long)
158 @ stdcall _adj_fdivr_m32(long)
159 @ stdcall _adj_fdivr_m32i(long)
160 @ stdcall _adj_fdivr_m64(double)
161 @ stub _adj_fpatan #()
162 @ stub _adj_fprem #()
163 @ stub _adj_fprem1 #()
164 @ stub _adj_fptan #()
165 @ extern _adjust_fdiv
166 # extern _aexit_rtn
167 @ stub _aligned_free #(ptr)
168 @ stub _aligned_malloc #(long long)
169 @ stub _aligned_offset_malloc #(long long long)
170 @ stub _aligned_offset_realloc #(ptr long long long)
171 @ stub _aligned_realloc #(ptr long long)
172 @ cdecl _amsg_exit(long)
173 @ cdecl _assert(str str long)
174 @ stub _atodbl #(ptr str)
175 @ cdecl -ret64 _atoi64(str) ntdll._atoi64
176 @ stub _atoldbl #(ptr str) MSVCRT__atoldbl
177 @ cdecl _beep(long long)
178 @ cdecl _beginthread (ptr long ptr)
179 @ cdecl _beginthreadex (ptr long ptr ptr long ptr)
180 @ cdecl _c_exit()
181 @ cdecl _cabs(long)
182 @ stub _callnewh #(long)
183 @ cdecl _cexit()
184 @ cdecl _cgets(str)
185 @ cdecl _chdir(str)
186 @ cdecl _chdrive(long)
187 @ cdecl _chgsign( double )
188 @ stub _chkesp #cdecl -i386 -norelay _chkesp()
189 @ cdecl _chmod(str long)
190 @ cdecl _chsize (long long)
191 @ cdecl _clearfp()
192 @ cdecl _close(long)
193 @ cdecl _commit(long)
194 @ extern _commode
195 @ cdecl _control87(long long)
196 @ cdecl _controlfp(long long)
197 @ cdecl _copysign( double double )
198 @ varargs _cprintf(str)
199 @ cdecl _cputs(str)
200 @ cdecl _creat(str long)
201 @ varargs _cscanf(str)
202 @ extern _ctype
203 @ cdecl _cwait(ptr long long)
204 @ extern _daylight
205 @ stub _dstbias #extern _dstbias MSVCRT__dstbias
206 @ cdecl _dup (long)
207 @ cdecl _dup2 (long long)
208 @ cdecl _ecvt(double long ptr ptr)
209 @ cdecl _endthread ()
210 @ cdecl _endthreadex(long)
211 @ extern _environ
212 @ cdecl _eof(long)
213 @ cdecl _errno()
214 @ cdecl _except_handler2(ptr ptr ptr ptr)
215 @ cdecl _except_handler3(ptr ptr ptr ptr)
216 @ varargs _execl(str str)
217 @ varargs _execle(str str)
218 @ varargs _execlp(str str)
219 @ varargs _execlpe(str str)
220 @ cdecl _execv(str str)
221 @ cdecl _execve(str str str)
222 @ cdecl _execvp(str str)
223 @ cdecl _execvpe(str str str)
224 @ cdecl _exit(long)
225 @ cdecl _expand(ptr long)
226 @ cdecl _fcloseall()
227 @ cdecl _fcvt(double long ptr ptr)
228 @ cdecl _fdopen(long str)
229 @ cdecl _fgetchar()
230 @ cdecl _fgetwchar()
231 @ cdecl _filbuf(ptr)
232 # extern _fileinfo
233 @ cdecl _filelength(long)
234 @ cdecl -ret64 _filelengthi64(long)
235 @ cdecl _fileno(ptr)
236 @ cdecl _findclose(long)
237 @ cdecl _findfirst(str ptr)
238 @ cdecl _findfirsti64(str ptr)
239 @ cdecl _findnext(long ptr)
240 @ cdecl _findnexti64(long ptr)
241 @ cdecl _finite( double )
242 @ cdecl _flsbuf(long ptr)
243 @ cdecl _flushall()
244 @ extern _fmode
245 @ cdecl _fpclass(double)
246 @ stub _fpieee_flt #(long ptr ptr)
247 @ cdecl _fpreset()
248 @ cdecl _fputchar(long)
249 @ cdecl _fputwchar(long)
250 @ cdecl _fsopen(str str long)
251 @ cdecl _fstat(long ptr)
252 @ stub _fstat64 #(long ptr) MSVCRT__fstat64
253 @ cdecl _fstati64(long ptr)
254 @ cdecl _ftime(ptr)
255 @ cdecl -ret64 _ftol() ntdll._ftol
256 @ cdecl _fullpath(ptr str long)
257 @ cdecl _futime(long ptr)
258 @ cdecl _gcvt(double long str)
259 @ cdecl _get_osfhandle(long)
260 @ stub _get_sbh_threshold #()
261 @ stub _get_terminate
262 @ stub _get_unexpected
263 @ cdecl _getch()
264 @ cdecl _getche()
265 @ cdecl _getcwd(str long)
266 @ cdecl _getdcwd(long str long)
267 @ cdecl _getdiskfree(long ptr)
268 @ cdecl _getdllprocaddr(long str long)
269 @ cdecl _getdrive()
270 @ cdecl _getdrives() kernel32.GetLogicalDrives
271 @ stub _getmaxstdio #()
272 @ stub _getmbcp #()
273 @ cdecl _getpid() kernel32.GetCurrentProcessId
274 @ stub _getsystime #(ptr)
275 @ cdecl _getw(ptr)
276 @ cdecl _getws(ptr)
277 @ cdecl _global_unwind2(ptr)
278 @ cdecl _heapadd (ptr long)
279 @ cdecl _heapchk()
280 @ cdecl _heapmin()
281 @ cdecl _heapset(long)
282 @ stub _heapused #(ptr ptr)
283 @ cdecl _heapwalk(ptr)
284 @ cdecl _hypot(double double)
285 @ cdecl _i64toa(long long ptr long) ntdll._i64toa
286 @ cdecl _i64tow(long long ptr long) ntdll._i64tow
287 @ cdecl _initterm(ptr ptr)
288 @ stub _inp #(long) -i386
289 @ stub _inpd #(long) -i386
290 @ stub _inpw #(long) -i386
291 @ extern _iob
292 @ cdecl _isatty(long)
293 @ cdecl _isctype(long long)
294 @ stub _ismbbalnum #(long)
295 @ stub _ismbbalpha #(long)
296 @ stub _ismbbgraph #(long)
297 @ stub _ismbbkalnum #(long)
298 @ cdecl _ismbbkana(long)
299 @ stub _ismbbkprint #(long)
300 @ stub _ismbbkpunct #(long)
301 @ cdecl _ismbblead(long)
302 @ stub _ismbbprint #(long)
303 @ stub _ismbbpunct #(long)
304 @ cdecl _ismbbtrail(long)
305 @ cdecl _ismbcalnum(long)
306 @ cdecl _ismbcalpha(long)
307 @ cdecl _ismbcdigit(long)
308 @ stub _ismbcgraph #(long)
309 @ cdecl _ismbchira(long)
310 @ cdecl _ismbckata(long)
311 @ stub _ismbcl0 #(long)
312 @ stub _ismbcl1 #(long)
313 @ stub _ismbcl2 #(long)
314 @ stub _ismbclegal #(long)
315 @ cdecl _ismbclower(long)
316 @ cdecl _ismbcprint(long)
317 @ stub _ismbcpunct #(long)
318 @ cdecl _ismbcspace(long)
319 @ cdecl _ismbcsymbol(long)
320 @ cdecl _ismbcupper(long)
321 @ cdecl _ismbslead(ptr ptr)
322 @ cdecl _ismbstrail(ptr ptr)
323 @ cdecl _isnan( double )
324 @ cdecl _itoa(long ptr long) ntdll._itoa
325 @ cdecl _itow(long ptr long) ntdll._itow
326 @ cdecl _j0(double)
327 @ cdecl _j1(double)
328 @ cdecl _jn(long double)
329 @ cdecl _kbhit()
330 @ cdecl _lfind(ptr ptr ptr long ptr)
331 @ cdecl _loaddll(str)
332 @ cdecl -i386 _local_unwind2(ptr long)
333 @ cdecl _lock(long)
334 @ cdecl _locking(long long long)
335 @ cdecl _logb( double )
336 @ stub -i386 _longjmpex #(ptr long) MSVCRT_longjmp
337 @ cdecl _lrotl(long long)
338 @ cdecl _lrotr(long long)
339 @ cdecl _lsearch(ptr ptr long long ptr)
340 @ cdecl _lseek(long long long)
341 @ cdecl -ret64 _lseeki64(long double long)
342 @ cdecl _ltoa(long ptr long) ntdll._ltoa
343 @ cdecl _ltow(long ptr long)
344 @ cdecl _makepath(ptr str str str str)
345 @ stub _matherr #(ptr) MSVCRT__matherr
346 @ cdecl _mbbtombc(long)
347 @ cdecl _mbbtype(long long)
348 # extern _mbcasemap
349 @ cdecl _mbccpy (str str)
350 @ cdecl _mbcjistojms(long)
351 @ cdecl _mbcjmstojis(long)
352 @ cdecl _mbclen(ptr)
353 @ cdecl _mbctohira(long)
354 @ cdecl _mbctokata(long)
355 @ cdecl _mbctolower(long)
356 @ cdecl _mbctombb(long)
357 @ cdecl _mbctoupper(long)
358 @ extern _mbctype
359 @ cdecl _mbsbtype(str long)
360 @ cdecl _mbscat(str str)
361 @ cdecl _mbschr(str long)
362 @ cdecl _mbscmp(str str)
363 @ cdecl _mbscoll(str str)
364 @ cdecl _mbscpy(ptr str)
365 @ cdecl _mbscspn (str str)
366 @ cdecl _mbsdec(ptr ptr)
367 @ cdecl _mbsdup(str) _strdup
368 @ cdecl _mbsicmp(str str)
369 @ cdecl _mbsicoll(str str)
370 @ cdecl _mbsinc(str)
371 @ cdecl _mbslen(str)
372 @ cdecl _mbslwr(str)
373 @ cdecl _mbsnbcat (str str long)
374 @ cdecl _mbsnbcmp(str str long)
375 @ cdecl _mbsnbcnt(ptr long)
376 @ cdecl _mbsnbcoll(str str long)
377 @ cdecl _mbsnbcpy(ptr str long)
378 @ stub _mbsnbcpy_s #(ptr long str long)
379 @ cdecl _mbsnbicmp(str str long)
380 @ cdecl _mbsnbicoll(str str long)
381 @ cdecl _mbsnbset(str long long)
382 @ cdecl _mbsncat(str str long)
383 @ cdecl _mbsnccnt(str long)
384 @ cdecl _mbsncmp(str str long)
385 @ cdecl _mbsncoll (str str long)
386 @ cdecl _mbsncpy(str str long)
387 @ cdecl _mbsnextc(str)
388 @ cdecl _mbsnicmp(str str long)
389 @ cdecl _mbsnicoll (str str long)
390 @ cdecl _mbsninc(str long)
391 @ cdecl _mbsnset(str long long)
392 @ cdecl _mbspbrk(str str)
393 @ cdecl _mbsrchr(str long)
394 @ cdecl _mbsrev(str)
395 @ cdecl _mbsset(str long)
396 @ cdecl _mbsspn(str str)
397 @ cdecl _mbsspnp(str str)
398 @ cdecl _mbsstr(str str)
399 @ cdecl _mbstok(str str)
400 @ cdecl _mbstrlen(str)
401 @ cdecl _mbsupr(str)
402 @ cdecl _memccpy(ptr ptr long long)
403 @ cdecl _memicmp(str str long) ntdll._memicmp
404 @ cdecl _mkdir(str)
405 @ cdecl _mktemp(str)
406 @ cdecl _msize(ptr)
407 @ cdecl _nextafter(double double)
408 @ cdecl _onexit(ptr)
409 @ varargs _open(str long)
410 @ cdecl _open_osfhandle(long long)
411 @ extern _osver
412 @ stub _outp #(long long)
413 @ stub _outpd #(long long)
414 @ stub _outpw #(long long)
415 @ cdecl _pclose (ptr)
416 @ extern _pctype
417 @ extern _pgmptr
418 @ cdecl _pipe (ptr long long)
419 @ cdecl _popen (str str)
420 @ cdecl _purecall()
421 @ cdecl _putch(long)
422 @ cdecl _putenv(str)
423 @ cdecl _putw(long ptr)
424 @ cdecl _putws(wstr)
425 # extern _pwctype
426 @ cdecl _read(long ptr long)
427 @ cdecl _rmdir(str)
428 @ cdecl _rmtmp()
429 @ cdecl _rotl(long long)
430 @ cdecl _rotr(long long)
431 @ stub _safe_fdiv #()
432 @ stub _safe_fdivr #()
433 @ stub _safe_fprem #()
434 @ stub _safe_fprem1 #()
435 @ cdecl _scalb( double long)
436 @ cdecl _searchenv(str str ptr)
437 @ stdcall -i386 _seh_longjmp_unwind(ptr)
438 @ stub _set_error_mode #(long)
439 @ stub _set_sbh_threshold #(long)
440 @ cdecl _seterrormode(long)
441 @ cdecl -i386 -norelay _setjmp(ptr)
442 @ cdecl -i386 -norelay _setjmp3(ptr long)
443 @ stub _setmaxstdio #(long)
444 @ cdecl _setmbcp(long)
445 @ cdecl _setmode(long long)
446 @ cdecl _setsystime (ptr long)
447 @ cdecl _sleep(long)
448 @ varargs _snprintf(str long str) crt__snprintf
449 @ varargs _snwprintf(wstr long wstr) crt__snwprintf
450 @ varargs _sopen(str long long)
451 @ varargs _spawnl(long str str)
452 @ varargs _spawnle(long str str)
453 @ varargs _spawnlp(long str str)
454 @ varargs _spawnlpe(long str str)
455 @ cdecl _spawnv(long str ptr)
456 @ cdecl _spawnve(long str ptr ptr)
457 @ cdecl _spawnvp(long str ptr)
458 @ cdecl _spawnvpe(long str ptr ptr)
459 @ cdecl _splitpath(str ptr ptr ptr ptr) ntdll._splitpath
460 @ cdecl _stat(str ptr)
461 @ stub _stat64 #(str ptr) MSVCRT__stat64
462 @ cdecl _stati64(str ptr)
463 @ cdecl _statusfp()
464 @ cdecl _strcmpi(str str)
465 @ cdecl _strdate(ptr)
466 @ cdecl _strdup(str)
467 @ cdecl _strerror(long)
468 @ cdecl _stricmp(str str) ntdll._stricmp
469 @ cdecl _stricoll(str str)
470 @ cdecl _strlwr(str) ntdll._strlwr
471 @ cdecl _strncoll(str str long)
472 @ cdecl _strnicmp(str str long) ntdll._strnicmp
473 @ cdecl _strnicoll(str str long)
474 @ cdecl _strnset(str long long)
475 @ cdecl _strrev(str)
476 @ cdecl _strset(str long)
477 @ cdecl _strtime(ptr)
478 @ cdecl _strupr(str)
479 @ cdecl _swab(str str long)
480 @ extern _sys_errlist
481 @ extern _sys_nerr
482 @ cdecl _tell(long)
483 @ cdecl -ret64 _telli64(long)
484 @ cdecl _tempnam(str str)
485 @ extern _timezone
486 @ cdecl _tolower(long) ntdll._tolower
487 @ cdecl _toupper(long) ntdll._toupper
488 @ extern _tzname
489 @ cdecl _tzset()
490 @ cdecl _ui64toa(long long ptr long) ntdll._ui64toa
491 @ cdecl _ui64tow(long long ptr long) ntdll._ui64tow
492 @ cdecl _ultoa(long ptr long) ntdll._ultoa
493 @ cdecl _ultow(long ptr long) ntdll._ultow
494 @ cdecl _umask(long)
495 @ cdecl _ungetch(long)
496 @ cdecl _unlink(str)
497 @ cdecl _unloaddll(long)
498 @ cdecl _unlock(long)
499 @ cdecl _utime(str ptr)
500 @ cdecl _vsnprintf(ptr long ptr ptr)
501 @ cdecl _vsnwprintf(ptr long wstr long)
502 @ cdecl _waccess(wstr long)
503 @ cdecl _wasctime(ptr)
504 @ cdecl _wchdir(wstr)
505 @ cdecl _wchmod(wstr long)
506 @ extern _wcmdln
507 @ cdecl _wcreat(wstr long)
508 @ cdecl _wcsdup(wstr)
509 @ cdecl _wcsicmp(wstr wstr)
510 @ cdecl _wcsicoll(wstr wstr)
511 @ cdecl _wcslwr(wstr)
512 @ cdecl _wcsncoll (wstr wstr long)
513 @ cdecl _wcsnicmp(wstr wstr long)
514 @ cdecl _wcsnicoll (wstr wstr long)
515 @ cdecl _wcsnset(wstr long long)
516 @ cdecl _wcsrev(wstr)
517 @ cdecl _wcsset(wstr long)
518 @ cdecl _wcsupr(wstr)
519 @ cdecl _wctime(ptr)
520 @ extern _wenviron
521 @ varargs _wexecl (wstr wstr)
522 @ varargs _wexecle (wstr wstr)
523 @ varargs _wexeclp (wstr wstr)
524 @ varargs _wexeclpe (wstr wstr)
525 @ cdecl _wexecv (wstr ptr)
526 @ cdecl _wexecve (wstr ptr ptr)
527 @ cdecl _wexecvp (wstr ptr)
528 @ cdecl _wexecvpe (wstr ptr ptr)
529 @ cdecl _wfdopen(long wstr)
530 @ cdecl _wfindfirst(wstr ptr)
531 @ cdecl _wfindfirsti64(wstr ptr)
532 @ cdecl _wfindnext(long ptr)
533 @ cdecl _wfindnexti64 (long ptr)
534 @ cdecl _wfopen(wstr wstr)
535 @ cdecl _wfreopen (wstr wstr ptr)
536 @ cdecl _wfsopen(wstr wstr long)
537 @ cdecl _wfullpath(ptr wstr long)
538 @ cdecl _wgetcwd(wstr long)
539 @ cdecl _wgetdcwd(long wstr long)
540 @ cdecl _wgetenv(wstr)
541 @ extern _winmajor
542 @ extern _winminor
543 @ extern _winver
544 @ cdecl _wmakepath(wstr wstr wstr wstr wstr)
545 @ cdecl _wmkdir(wstr)
546 @ cdecl _wmktemp(wstr)
547 @ varargs _wopen(wstr long)
548 @ stub _wperror #(wstr)
549 @ stub _wpgmptr #extern _wpgmptr MSVCRT__wpgmptr
550 @ cdecl _wpopen (wstr wstr)
551 @ cdecl _wputenv(wstr)
552 @ cdecl _wremove(wstr)
553 @ cdecl _wrename(wstr wstr)
554 @ cdecl _write(long ptr long)
555 @ cdecl _wrmdir(wstr)
556 @ cdecl _wsearchenv(wstr wstr ptr)
557 @ stub _wsetlocale #(long wstr) MSVCRT__wsetlocale
558 @ varargs _wsopen (wstr long long)
559 @ stub _wspawnl #(long wstr wstr) varargs
560 @ stub _wspawnle #(long wstr wstr) varargs
561 @ stub _wspawnlp #(long wstr wstr) varargs
562 @ stub _wspawnlpe #(long wstr wstr) varargs
563 @ cdecl _wspawnv(long wstr ptr)
564 @ cdecl _wspawnve(long wstr ptr ptr)
565 @ cdecl _wspawnvp(long wstr ptr)
566 @ cdecl _wspawnvpe(long wstr ptr ptr)
567 @ cdecl _wsplitpath(wstr wstr wstr wstr wstr)
568 @ cdecl _wstat(wstr ptr)
569 @ cdecl _wstati64(wstr ptr)
570 @ stub _wstat64 #(wstr ptr) MSVCRT__wstat64
571 @ cdecl _wstrdate(ptr)
572 @ cdecl _wstrtime(ptr)
573 @ stub _wsystem #(wstr)
574 @ cdecl _wtempnam(wstr wstr)
575 @ stub _wtmpnam #(ptr)
576 @ cdecl _wtoi(wstr) ntdll._wtoi
577 @ cdecl _wtoi64(wstr) ntdll._wtoi64
578 @ cdecl _wtol(wstr) ntdll._wtol
579 @ cdecl _wunlink(wstr)
580 @ cdecl _wutime(wstr ptr)
581 @ cdecl _y0(double)
582 @ cdecl _y1(double)
583 @ cdecl _yn(long double )
584 @ cdecl abort() abort
585 @ cdecl abs(long) ntdll.abs
586 @ cdecl acos(double) acos
587 @ cdecl asctime(ptr) asctime
588 @ cdecl asin(double) asin
589 @ cdecl atan(double) ntdll.atan
590 @ cdecl atan2(double double) atan2
591 @ cdecl atexit(ptr) atexit
592 @ cdecl atof(str) atof
593 @ cdecl atoi(str) ntdll.atoi
594 @ cdecl atol(str) ntdll.atol
595 @ cdecl bsearch(ptr ptr long long ptr) ntdll.bsearch
596 @ cdecl calloc(long long) calloc
597 @ cdecl ceil(double) ntdll.ceil
598 @ cdecl clearerr(ptr) clearerr
599 @ cdecl clock() clock
600 @ cdecl cos(double) ntdll.cos
601 @ cdecl cosh(double) cosh
602 @ cdecl ctime(ptr) ctime
603 @ cdecl difftime(long long) difftime
604 @ cdecl div(long long) div
605 @ cdecl exit(long) exit
606 @ cdecl exp(double) exp
607 @ cdecl fabs(double) ntdll.fabs
608 @ cdecl fclose(ptr) fclose
609 @ cdecl feof(ptr) feof
610 @ cdecl ferror(ptr) ferror
611 @ cdecl fflush(ptr) fflush
612 @ cdecl fgetc(ptr) fgetc
613 @ cdecl fgetpos(ptr ptr) fgetpos
614 @ cdecl fgets(ptr long ptr) fgets
615 @ cdecl fgetwc(ptr) fgetwc
616 @ cdecl fgetws(ptr long ptr) fgetws
617 @ cdecl floor(double) ntdll.floor
618 @ cdecl fmod(double double) fmod
619 @ cdecl fopen(str str) fopen
620 @ varargs fprintf(ptr str) fprintf
621 @ cdecl fputc(long ptr) fputc
622 @ cdecl fputs(str ptr) fputs
623 @ cdecl fputwc(long ptr) fputwc
624 @ cdecl fputws(wstr ptr) fputws
625 @ cdecl fread(ptr long long ptr) fread
626 @ cdecl free(ptr) free
627 @ cdecl freopen(str str ptr) freopen
628 @ cdecl frexp(double ptr) frexp
629 @ varargs fscanf(ptr str) fscanf
630 @ cdecl fseek(ptr long long) fseek
631 @ cdecl fsetpos(ptr ptr) fsetpos
632 @ cdecl ftell(ptr) ftell
633 @ varargs fwprintf(ptr wstr) fwprintf
634 @ cdecl fwrite(ptr long long ptr) fwrite
635 @ varargs fwscanf(ptr wstr) fwscanf
636 @ cdecl getc(ptr) getc
637 @ cdecl getchar() getchar
638 @ cdecl getenv(str) getenv
639 @ cdecl gets(str) gets
640 @ cdecl getwc(ptr) getwc
641 @ cdecl getwchar() getwchar
642 @ cdecl gmtime(ptr) gmtime
643 @ cdecl is_wctype(long long) is_wctype
644 @ cdecl isalnum(long) ntdll.isalnum
645 @ cdecl isalpha(long) ntdll.isalpha
646 @ cdecl iscntrl(long) ntdll.iscntrl
647 @ cdecl isdigit(long) ntdll.isdigit
648 @ cdecl isgraph(long) ntdll.isgraph
649 @ cdecl isleadbyte(long) isleadbyte
650 @ cdecl islower(long) ntdll.islower
651 @ cdecl isprint(long) ntdll.isprint
652 @ cdecl ispunct(long) ntdll.ispunct
653 @ cdecl isspace(long) ntdll.isspace
654 @ cdecl isupper(long) ntdll.isupper
655 @ cdecl iswalnum(long) iswalnum
656 @ cdecl iswalpha(long) ntdll.iswalpha
657 @ cdecl iswascii(long) iswascii
658 @ cdecl iswcntrl(long) iswcntrl
659 @ cdecl iswctype(long long) ntdll.iswctype
660 @ cdecl iswdigit(long) ntdll.iswdigit
661 @ cdecl iswgraph(long) iswgraph
662 @ cdecl iswlower(long) ntdll.iswlower
663 @ cdecl iswprint(long) iswprint
664 @ cdecl iswpunct(long) iswpunct
665 @ cdecl iswspace(long) ntdll.iswspace
666 @ cdecl iswupper(long) iswupper
667 @ cdecl iswxdigit(long) ntdll.iswxdigit
668 @ cdecl isxdigit(long) ntdll.isxdigit
669 @ cdecl labs(long) ntdll.labs
670 @ cdecl ldexp( double long) ldexp
671 @ cdecl ldiv(long long) ldiv
672 @ cdecl localeconv() localeconv
673 @ cdecl localtime(ptr) localtime
674 @ cdecl log(double) ntdll.log
675 @ cdecl log10(double) log10
676 @ cdecl -i386 longjmp(ptr long) longjmp
677 @ cdecl malloc(long) malloc
678 @ cdecl mblen(ptr long) mblen
679 @ cdecl mbstowcs(ptr str long) ntdll.mbstowcs
680 @ cdecl mbtowc(wstr str long) mbtowc
681 @ cdecl memchr(ptr long long) memchr
682 @ cdecl memcmp(ptr ptr long) memcmp
683 @ cdecl memcpy(ptr ptr long) memcpy
684 @ cdecl memmove(ptr ptr long) memmove
685 @ cdecl memset(ptr long long) memset
686 @ cdecl mktime(ptr) mktime
687 @ cdecl modf(double ptr) modf
688 @ cdecl perror(str) perror
689 @ cdecl pow(double double) ntdll.pow
690 @ varargs printf(str) printf
691 @ cdecl putc(long ptr) putc
692 @ cdecl putchar(long) putchar
693 @ cdecl puts(str) puts
694 @ cdecl putwc(long ptr) putwc
695 @ cdecl putwchar(long) putwchar
696 @ cdecl qsort(ptr long long ptr) ntdll.qsort
697 @ cdecl raise(long) raise
698 @ cdecl rand() rand
699 @ cdecl realloc(ptr long) realloc
700 @ cdecl remove(str) remove
701 @ cdecl rename(str str) rename
702 @ cdecl rewind(ptr) rewind
703 @ varargs scanf(str) scanf
704 @ cdecl setbuf(ptr ptr) setbuf
705 @ cdecl setlocale(long str) setlocale
706 @ cdecl setvbuf(ptr str long long) setvbuf
707 @ cdecl signal(long long) signal
708 @ cdecl sin(double) ntdll.sin
709 @ cdecl sinh(double) sinh
710 @ varargs sprintf(ptr str) crt_sprintf
711 @ cdecl sqrt(double) ntdll.sqrt
712 @ cdecl srand(long) srand
713 @ varargs sscanf(str str) crt_sscanf
714 @ cdecl strcat(str str) ntdll.strcat
715 @ stub strcat_s #(str long str) MSVCRT_strcat_s
716 @ cdecl strchr(str long) strchr
717 @ cdecl strcmp(str str) ntdll.strcmp
718 @ cdecl strcoll(str str) strcoll
719 @ cdecl strcpy(ptr str) strcpy
720 @ stub strcpy_s #(ptr long str)
721 @ cdecl strcspn(str str) strcspn
722 @ cdecl strerror(long) strerror
723 @ cdecl strftime(str long str ptr) strftime
724 @ cdecl strlen(str) strlen
725 @ cdecl strncat(str str long) strncat
726 @ cdecl strncmp(str str long) strncmp
727 @ cdecl strncpy(ptr str long) strncpy
728 @ cdecl strpbrk(str str) strpbrk
729 @ cdecl strrchr(str long) strrchr
730 @ cdecl strspn(str str) strspn
731 @ cdecl strstr(str str) strstr
732 @ cdecl strtod(str ptr) strtod
733 @ cdecl strtok(str str) strtok
734 @ cdecl strtol(str ptr long) ntdll.strtol
735 @ cdecl strtoul(str ptr long) strtoul
736
737 # ReactOS hack {
738 @ cdecl _strtoui64(str ptr long) strtoull
739 # ReactOS hack }
740
741 @ cdecl strxfrm(ptr str long) strxfrm
742 @ varargs swprintf(wstr wstr) crt_swprintf
743 @ varargs swscanf(wstr wstr) swscanf
744 @ cdecl system(str) system
745 @ cdecl tan(double) ntdll.tan
746 @ cdecl tanh(double) tanh
747 @ cdecl time(ptr) time
748 @ cdecl tmpfile() tmpfile
749 @ cdecl tmpnam(ptr) tmpnam
750 @ cdecl tolower(long) ntdll.tolower
751 @ cdecl toupper(long) ntdll.toupper
752 @ cdecl towlower(long) ntdll.towlower
753 @ cdecl towupper(long) ntdll.towupper
754 @ cdecl ungetc(long ptr) ungetc
755 @ cdecl ungetwc(long ptr) ungetwc
756 @ cdecl vfprintf(ptr str long) vfprintf
757 @ cdecl vfwprintf(ptr wstr long) vfwprintf
758 @ cdecl vprintf(str long) vprintf
759 @ cdecl vsprintf(ptr str ptr) vsprintf
760 @ cdecl vswprintf(ptr wstr long) vswprintf
761 @ cdecl vwprintf(wstr long) vwprintf
762 @ cdecl wcscat(wstr wstr) wcscat
763 @ cdecl wcschr(wstr long) wcschr
764 @ cdecl wcscmp(wstr wstr) wcscmp
765 @ cdecl wcscoll(wstr wstr) wcscoll
766 @ cdecl wcscpy(ptr wstr) wcscpy
767 @ cdecl wcscspn(wstr wstr) wcscspn
768 @ cdecl wcsftime(ptr long wstr ptr) wcsftime
769 @ cdecl wcslen(wstr) wcslen
770 @ cdecl wcsncat(wstr wstr long) wcsncat
771 @ cdecl wcsncmp(wstr wstr long) wcsncmp
772 @ cdecl wcsncpy(ptr wstr long) wcsncpy
773 @ cdecl wcspbrk(wstr wstr) wcspbrk
774 @ cdecl wcsrchr(wstr long) ntdll.wcsrchr
775 @ cdecl wcsspn(wstr wstr) ntdll.wcsspn
776 @ cdecl wcsstr(wstr wstr) ntdll.wcsstr
777 @ cdecl wcstod(wstr ptr) wcstod
778 @ cdecl wcstok(wstr wstr) wcstok
779 @ cdecl wcstol(wstr ptr long) ntdll.wcstol
780 @ cdecl wcstombs(ptr ptr long) wcstombs
781 @ cdecl wcstoul(wstr ptr long) ntdll.wcstoul
782 @ cdecl wcsxfrm (ptr wstr long) wcsxfrm
783 @ cdecl wctomb(ptr long) wctomb
784 @ varargs wprintf(wstr) wprintf
785 @ varargs wscanf(wstr) wscanf