added stubs for CertGetNameStringA/W needed by eMule
[reactos.git] / reactos / lib / crypt32 / crypt32.spec
1 @ stdcall CertAddCRLContextToStore(long ptr long ptr)
2 @ stdcall CertAddCTLContextToStore(long ptr long ptr)
3 @ stdcall CertAddCertificateContextToStore(long ptr long ptr)
4 @ stdcall CertAddEncodedCRLToStore(long long ptr long long ptr)
5 @ stdcall CertAddEncodedCTLToStore(long long ptr long long ptr)
6 @ stdcall CertAddEncodedCertificateToStore(long long ptr long long ptr)
7 @ stub CertAddEncodedCertificateToSystemStoreA
8 @ stub CertAddEncodedCertificateToSystemStoreW
9 @ stub CertAddEnhancedKeyUsageIdentifier
10 @ stdcall CertAddSerializedElementToStore(ptr ptr long long long long ptr ptr)
11 @ stdcall CertAddStoreToCollection(ptr ptr long long)
12 @ stdcall CertAlgIdToOID(long)
13 @ stdcall CertCloseStore(ptr long)
14 @ stub CertCompareCertificate
15 @ stub CertCompareCertificateName
16 @ stub CertCompareIntegerBlob
17 @ stub CertComparePublicKeyInfo
18 @ stdcall CertControlStore(long long long ptr)
19 @ stdcall CertCreateCRLContext(long ptr long)
20 @ stdcall CertCreateCTLContext(long ptr long)
21 @ stub CertCreateCertificateChainEngine
22 @ stdcall CertCreateCertificateContext(long ptr long)
23 @ stdcall CertDeleteCRLFromStore(ptr)
24 @ stdcall CertDeleteCTLFromStore(ptr)
25 @ stdcall CertDeleteCertificateFromStore(ptr)
26 @ stub CertDuplicateCRLContext
27 @ stub CertDuplicateCTLContext
28 @ stdcall CertDuplicateCertificateContext(ptr)
29 @ stub CertDuplicateStore
30 @ stub CertEnumCRLContextProperties
31 @ stdcall CertEnumCRLsInStore(ptr ptr)
32 @ stub CertEnumCTLContextProperties
33 @ stdcall CertEnumCTLsInStore(ptr ptr)
34 @ stdcall CertEnumCertificateContextProperties(ptr long)
35 @ stdcall CertEnumCertificatesInStore(long ptr)
36 @ stdcall CertFindAttribute(str long ptr)
37 @ stub CertFindCTLInStore
38 @ stdcall CertFindCertificateInStore(long long long long ptr ptr)
39 @ stdcall CertFindExtension(str long ptr)
40 @ stdcall CertFindRDNAttr(str ptr)
41 @ stub CertFindSubjectInCTL
42 @ stdcall CertFreeCRLContext(ptr)
43 @ stdcall CertFreeCTLContext(ptr)
44 @ stub CertFreeCertificateChain
45 @ stub CertFreeCertificateChainEngine
46 @ stdcall CertFreeCertificateContext(ptr)
47 @ stdcall CertGetCRLContextProperty(ptr long ptr ptr)
48 @ stub CertGetCRLFromStore
49 @ stdcall CertGetCTLContextProperty(ptr long ptr ptr)
50 @ stub CertGetCertificateChain
51 @ stdcall CertGetCertificateContextProperty(ptr long ptr ptr)
52 @ stub CertGetEnhancedKeyUsage
53 @ stub CertGetIntendedKeyUsage
54 @ stub CertGetIssuerCertificateFromStore
55 @ stub CertGetNameStringA
56 @ stub CertGetNameStringW
57 @ stub CertGetPublicKeyLength
58 @ stub CertGetSubjectCertificateFromStore
59 @ stub CertIsRDNAttrsInCertificateName
60 @ stub CertNameToStrA
61 @ stub CertNameToStrW
62 @ stdcall CertOIDToAlgId(str)
63 @ stdcall CertOpenStore(str long long long ptr)
64 @ stdcall CertOpenSystemStoreA(long str)
65 @ stdcall CertOpenSystemStoreW(long wstr)
66 @ stub CertRDNValueToStrA
67 @ stub CertRDNValueToStrW
68 @ stub CertRemoveEnhancedKeyUsageIdentifier
69 @ stdcall CertRemoveStoreFromCollection(long long)
70 @ stdcall CertSaveStore(long long long long ptr long)
71 @ stdcall CertSerializeCRLStoreElement(ptr long ptr ptr)
72 @ stdcall CertSerializeCTLStoreElement(ptr long ptr ptr)
73 @ stdcall CertSerializeCertificateStoreElement(ptr long ptr ptr)
74 @ stdcall CertSetCRLContextProperty(ptr long long ptr)
75 @ stdcall CertSetCTLContextProperty(ptr long long ptr)
76 @ stdcall CertSetCertificateContextProperty(ptr long long ptr)
77 @ stub CertSetEnhancedKeyUsage
78 @ stub CertStrToNameA
79 @ stub CertStrToNameW
80 @ stub CertVerifyCRLRevocation
81 @ stub CertVerifyCRLTimeValidity
82 @ stub CertVerifyCTLUsage
83 @ stub CertVerifyRevocation
84 @ stub CertVerifySubjectCertificateContext
85 @ stdcall CertVerifyTimeValidity(ptr ptr)
86 @ stub CertVerifyValidityNesting
87 @ stub CreateFileU
88 @ stub CryptAcquireContextU
89 @ stub CryptCloseAsyncHandle
90 @ stub CryptCreateAsyncHandle
91 @ stub CryptDecodeMessage
92 @ stdcall CryptDecodeObject(long str ptr long long ptr ptr)
93 @ stdcall CryptDecodeObjectEx(long str ptr long long ptr ptr ptr)
94 @ stub CryptDecryptAndVerifyMessageSignature
95 @ stub CryptDecryptMessage
96 @ stdcall CryptEncodeObject(long str ptr ptr ptr)
97 @ stdcall CryptEncodeObjectEx(long str ptr long ptr ptr ptr)
98 @ stub CryptEncryptMessage
99 @ stub CryptEnumOIDFunction
100 @ stub CryptEnumOIDInfo
101 @ stub CryptEnumProvidersU
102 @ stub CryptExportPKCS8
103 @ stdcall CryptExportPublicKeyInfo(long long long ptr ptr)
104 @ stdcall CryptExportPublicKeyInfoEx(long long long str long ptr ptr ptr)
105 @ stub CryptFindOIDInfo
106 @ stub CryptFormatObject
107 @ stub CryptFreeOIDFunctionAddress
108 @ stub CryptGetAsyncParam
109 @ stub CryptGetDefaultOIDDllList
110 @ stub CryptGetDefaultOIDFunctionAddress
111 @ stub CryptGetMessageCertificates
112 @ stub CryptGetMessageSignerCount
113 @ stub CryptGetOIDFunctionAddress
114 @ stdcall CryptGetOIDFunctionValue(long str str wstr ptr ptr ptr)
115 @ stdcall CryptHashCertificate(long long long ptr long ptr ptr)
116 @ stub CryptHashMessage
117 @ stub CryptHashPublicKeyInfo
118 @ stub CryptHashToBeSigned
119 @ stub CryptImportPKCS8
120 @ stdcall CryptImportPublicKeyInfo(long long ptr ptr)
121 @ stdcall CryptImportPublicKeyInfoEx(long long ptr long long ptr ptr)
122 @ stdcall CryptInitOIDFunctionSet(str long)
123 @ stub CryptInstallOIDFunctionAddress
124 @ stub CryptLoadSip
125 @ stdcall CryptMemAlloc(long)
126 @ stdcall CryptMemFree(ptr)
127 @ stdcall CryptMemRealloc(ptr long)
128 @ stub CryptMsgCalculateEncodedLength
129 @ stub CryptMsgClose
130 @ stub CryptMsgControl
131 @ stub CryptMsgCountersign
132 @ stub CryptMsgCountersignEncoded
133 @ stub CryptMsgEncodeAndSignCTL
134 @ stub CryptMsgGetAndVerifySigner
135 @ stub CryptMsgGetParam
136 @ stub CryptMsgOpenToDecode
137 @ stub CryptMsgOpenToEncode
138 @ stub CryptMsgSignCTL
139 @ stub CryptMsgUpdate
140 @ stub CryptMsgVerifyCountersignatureEncoded
141 @ stdcall CryptProtectData(ptr wstr ptr ptr ptr long ptr)
142 @ stdcall CryptRegisterDefaultOIDFunction(long str long wstr)
143 @ stdcall CryptRegisterOIDFunction(long str str wstr str)
144 @ stub CryptRegisterOIDInfo
145 @ stdcall CryptSIPAddProvider(ptr)
146 @ stdcall CryptSIPLoad(ptr long ptr)
147 @ stdcall CryptSIPRemoveProvider(ptr)
148 @ stdcall CryptSIPRetrieveSubjectGuid(wstr long ptr)
149 @ stub CryptSetAsyncParam
150 @ stdcall CryptSetOIDFunctionValue(long str str wstr long ptr long)
151 @ stub CryptSetProviderU
152 @ stub CryptSignAndEncodeCertificate
153 @ stub CryptSignAndEncryptMessage
154 @ stdcall CryptSignCertificate(long long long ptr long ptr ptr ptr ptr)
155 @ stub CryptSignHashU
156 @ stub CryptSignMessage
157 @ stub CryptSignMessageWithKey
158 @ stdcall CryptUnprotectData(ptr ptr ptr ptr ptr long ptr)
159 @ stdcall CryptUnregisterDefaultOIDFunction(long str wstr)
160 @ stdcall CryptUnregisterOIDFunction(long str str)
161 @ stub CryptUnregisterOIDInfo
162 @ stdcall CryptVerifyCertificateSignature(long long ptr long ptr)
163 @ stdcall CryptVerifyCertificateSignatureEx(long long long ptr long ptr long ptr)
164 @ stub CryptVerifyDetachedMessageHash
165 @ stub CryptVerifyDetachedMessageSignature
166 @ stub CryptVerifyMessageHash
167 @ stub CryptVerifyMessageSignature
168 @ stub CryptVerifyMessageSignatureWithKey
169 @ stub CryptVerifySignatureU
170 @ stdcall I_CryptAllocTls()
171 @ stdcall I_CryptCreateLruCache(long long)
172 @ stub I_CryptCreateLruEntry
173 @ stdcall I_CryptDetachTls(long)
174 @ stdcall I_CryptFindLruEntryData(long)
175 @ stdcall I_CryptFlushLruCache(long)
176 @ stdcall I_CryptFreeLruCache(long)
177 @ stdcall I_CryptFreeTls(long long)
178 @ stub I_CryptGetDefaultCryptProv
179 @ stub I_CryptGetDefaultCryptProvForEncrypt
180 @ stub I_CryptGetOssGlobal
181 @ stdcall I_CryptGetTls(long)
182 @ stub I_CryptInsertLruEntry
183 @ stub I_CryptInstallOssGlobal
184 @ stub I_CryptReleaseLruEntry
185 @ stdcall I_CryptSetTls(long ptr)
186 @ stub I_CryptUninstallOssGlobal
187 @ stub PFXExportCertStore
188 @ stub PFXImportCertStore
189 @ stub RegCreateHKCUKeyExU
190 @ stub RegCreateKeyExU
191 @ stub RegDeleteValueU
192 @ stub RegEnumValueU
193 @ stub RegOpenHKCUKeyExU
194 @ stub RegOpenKeyExU
195 @ stub RegQueryInfoKeyU
196 @ stub RegQueryValueExU
197 @ stub RegSetValueExU