[MSIEXEC] Sync with Wine Staging 2.16. CORE-13762
[reactos.git] / base / system / smss / CMakeLists.txt
index 736a051..0515061 100644 (file)
@@ -1,34 +1,21 @@
 
-include_directories(${REACTOS_SOURCE_DIR}/include/reactos/subsys)
+include_directories(${REACTOS_SOURCE_DIR}/sdk/include/reactos/subsys)
 
 list(APPEND SOURCE
-    client.c
-    debug.c
-    init.c
-    initdosdev.c
-    initenv.c
-    initheap.c
-    initmv.c
-    initobdir.c
-    initpage.c
-    initreg.c
-    initrun.c
-    initss.c
-    initwkdll.c
-    print.c
-    smapi.c
-    smapicomp.c
-    smapiexec.c
-    smapiquery.c
+    crashdmp.c
+    pagefile.c
+    sminit.c
+    smloop.c
+    smsbapi.c
+    smsessn.c
+    smsubsys.c
+    smutil.c
     smss.c
-    smss.rc)
-
-add_executable(smss WIN32 ${SOURCE})
-
-target_link_libraries(smss nt smlib)
-
-add_pch(smss smss.h)
+    smss.h)
 
+add_executable(smss WIN32 ${SOURCE} smss.rc)
+target_link_libraries(smss nt ${PSEH_LIB} smlib)
 set_module_type(smss nativecui)
 add_importlibs(smss ntdll)
+add_pch(smss smss.h SOURCE)
 add_cd_file(TARGET smss DESTINATION reactos/system32 FOR all)