[CMAKE/CLANG-CL] Silence some clang-cl warnings in consistency with our gcc build.
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index 1bace8f..07d927d 100644 (file)
@@ -47,9 +47,6 @@ endif()
 add_pch(libxslt precomp.h SOURCE)
 add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)
 
-if(NOT MSVC)
+if(USE_CLANG_CL OR (NOT MSVC))
     add_target_compile_flags(libxslt "-Wno-pointer-sign -Wno-unused-function")
-    if(NOT CMAKE_C_COMPILER_ID STREQUAL "Clang")
-        add_target_compile_flags(libxslt "-Wno-unused-but-set-variable")
-    endif()
 endif()