Synchronize with trunk revision 59636 (just before Alex's CreateProcess revamp).
[reactos.git] / dll / 3rdparty / libxslt / CMakeLists.txt
index 882cef3..3914bc1 100644 (file)
@@ -1,4 +1,7 @@
 
+include_directories(${CMAKE_CURRENT_SOURCE_DIR}
+                    ${REACTOS_SOURCE_DIR}/include/reactos/libs/libxslt)
+
 add_definitions(
     -DHAVE_CONFIG_H
     -DWIN32
@@ -31,7 +34,7 @@ add_library(libxslt SHARED
     xsltlocale.c
     xsltutils.c)
 
-set_entrypoint(libxslt 0)
+set_module_type(libxslt win32dll)
 target_link_libraries(libxslt libxml2)
 add_importlibs(libxslt msvcrt ws2_32 kernel32)
 
@@ -40,4 +43,10 @@ if(MSVC)
 endif()
 
 add_dependencies(libxslt psdk)
+add_pch(libxslt libxslt.h)
 add_cd_file(TARGET libxslt DESTINATION reactos/system32 FOR all)
+
+if(NOT MSVC)
+    add_target_compile_flags(libxslt "-Wno-pointer-sign -Wno-unused-but-set-variable -Wno-unused-function")
+    allow_warnings(libxslt)
+endif()