[TOOLS] Fix/suppress all MSVC/x64 warnings (#1525)
[reactos.git] / sdk / tools / hhpcomp / CMakeLists.txt
index bbe004a..8e073ff 100644 (file)
@@ -14,3 +14,11 @@ add_definitions(-DNONSLIDE)
 
 add_executable(hhpcomp ${SOURCE})
 target_link_libraries(hhpcomp)
+
+if(MSVC)
+    # Disable warning "'x': unreferenced local variable"
+    add_target_compile_flags(hhpcomp "/wd4101")
+
+    # Disable warning "'=': conversion from 'a' to 'b', possible loss of data"
+    add_target_compile_flags(hhpcomp "/wd4244")
+endif()